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1 OVERVIEW 
The purpose of this document is to give an overview of the ICM-3063XX eMD Developer Kit that will allow users to create a 
custom application using sensors. This document may also serve as a quick start guide for the ICM-306XX package and its 
elements, including how to setup and use provided samples applications. 

 

1.1. INTRODUCTION 

The ICM-306XX eMD solution is compatible with the Arduino Zero and is based on GCC development tools. The purpose of this 
solution is to allow sensor management and algorithm processing by using a standalone microcontroller. The ICM-306XX eMD 
solution was created as an advanced sensor hub, easy to integrate for users developing in wearable and IoT space. The 
Developer Kit includes a full sensor software solution; additional memory space is available on chip for users to program with 
their own logic. 

 

1.2. ICM-306XX EMD BASICS 

1.2.1. Overview 

The ICM-306XX chip uses three different processors: an ARM Cortex-M0, a DMP3 (only for ICM-30630), and a DMP4. 

The DMP3 (Digital Motion Processor 3) aims at offloading motion processing from the CPU, and provides ready-to-use physical 
and virtual sensors based on the Android L requirements. The DMP image has 6-axis (Accelerometer + Gyroscope) support 
including calibration. 

The DMP4 (Digital Motion Processor 4) is a higher functioning processor with specialties in fixed point Q30 processing and 16-bit 
FFT. The DMP4 complements the CPU by offloading computationally intensive operations. 

 

ICM-30630 ICM-30670 

 

 
 

Figure 1 – ICM-306XX eMD Architecture 

 

1.2.2. ICM-306XX eMD Hardware Layout 

The Arduino Zero board communicates with the ICM-306XX through SPI, providing a fast communication pathway. One interrupt 
line ais required from the ICM-306XX to connect to a wake-up pin. On Arduino Zero, the wake-up interrupt (GPIO0) is connected 
to pin J102-D5. This interrupt signal events according to the Android L specification, and allow the application to sleep in order 
to save power.  

External sensors are available on the sensor daughter board and connect to the ICM-306XX using I2C. The daughter board 
includes a magnetometer, a proximity sensor, and a pressure sensor. 
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2. SOFTWARE DEVELOPMENT PLATFORM 

2.1. SOLUTION PLATFORM 

This section will describe the hardware components needed to setup the ICM-306XX eMD solution. The proposed solution 
platform includes: 

- The Arduino Zero Board - Application board with a standalone microcontroller. For more information about the 
Arduino Zero board, please refer to Arduino website (see Useful Links section above.) 
 

- The ICM-306XX eMD Shield- Includes the ICM-306XX chip. All connectors at the back of the shield will be connected to 
Arduino Zero pins. 
The board can support two additional daughter boards to be connected to the front connectors.  

Be careful of the jumper’s configuration: they must be set as below: 

o JP1 : connect VDD to VDDIO 
o JP2 : connect VDD to 3V3 
o JP3 : open 

 

Figure 2 –ICM-30630 eMD Shield 

- The Sensor Daughter Board is optional but adds available external sensors -- magnetometer, proximity sensor and 
pressure sensor. Please plug the board as described on the picture above. 

Jumpers’ configuration:   

o J100 : [1<->2] close, [3<->4] close, [5<->6] open, [7<->8] open 

 

 

2.2. DIRECTORY STRUCTURE 

The InvenSense ICM-306XX eMD package includes all the necessary files to create a custom application. There are two parts in 
the installed package: 

- Examples: Included are application sample codes that use the InvenSense library to communicate with ICM-306XX 
eMD. All the sample codes contain an .ino file that is compatible with Arduino IDE. (For more information about sample 
code, please refer to Section 4). 
 

- src: Library sources needed to interface with ICM-306XX eMD. 
o Bridge: Library sources needed to encapsulate protocol to communicate with SensorStudio. 
o INVN: Libraries to communicate with ICM-306XX eMD include: 

 Devices: Contains InvenSense Device Driver library that defines API methods to control and retrieve 
data from InvenSense devices 
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 FifoProtocol: Contains InvenSense FIFO Protocol to communicate with ICM-306XX eMD 
 Utils: Contains helper sources for these libraries 

o Arduino Adapter: Contains adapter layout for SPI communication between Arduino Zero and ICM-306XX eMD 
o DeviceIoHal: Contains HAL for SPI communication using Arduino API 
o EasyDevice: Contains simplified layout to access the InvenSense Device Driver library 

 

2.3. PROJECTS 

The InvenSense ICM-306XX eMD package includes projects for very basic functionalities. The basic projects listed below can be 
used as starting points for application developments. For more details, please refer to Section 4. 

 The Bridge project is used to interface with the SensorStudio tool (please refer to SensorStudio Documentation for more 
information). 
 

 The AccAndGyrCalibration project consists of sample code to compute calibration coefficients in order to have accurate 
bias computed for accelerometer and gyroscope sensors. This sample code generates calibration tables that can be used 
directly in other application. Please, refer to “DoorOpeningDetection” sample code (Section 4.2) that explains how to use 
calibration tables. 

The “Detection” projects consist of sample codes that demonstrate how to use the ICM-306XX eMD Developer Kit to detect 
wanted events. They can be use as reference for developing a detecting application. 

 The DoorOpeningDetection project shows how to detect a door opening. When the gesture is detected, an LED blinks on 
Arduino Zero to inform the user. 

 
 The GestureDetection project demonstrates how to detect two types of gestures – a tilting gesture or a “SMD” gesture (for 

Significant Motion Detection). For each event detected, a message is printed on the Arduino Serial Monitor (for more 
information on this monitor, please refer to Section 3.3). 

The “GetData” project demonstrates very simple uses of the InvenSense Device Driver library to get different sensor data from 
the ICM-306XX eMD and the Sensor Daughter board. They can be used as references for examples to develop sensor data 
processing applications. 

 GetAccelerometerData -- this sample code shows how to get calibrated accelerometer data. Data is read from the 
accelerometer sensor integrated in ICM-306XX eMD and printed on Arduino Serial Monitor. 

 
 GetExternalSensors -- this sample code shows how to get data from external sensors available on the Sensor Daughter 

Board: Proximity, Pressure and Magnetometer sensors. All data is printed on the Arduino Serial Monitor. 
 

 GetGameRotationVector -- this sample code shows how to get quaternion data, which represents orientation of the device 
based on accelerometer and gyroscope 

 
  sensor data. Data is read from the sensors available on ICM-306XX eMD, computed by the processors, and printed on 

Arduino Serial Monitor. 

 

2.4. SETTING UP THE DEVELOPMENT ENVIRONMENT  

Before processing further, it is necessary to set up the Integrated Development Environment (IDE) in order to browse through 
the relevant projects and view code. All embedded software is developed using Arduino IDE. This section provides information 
on where to find this software and how to properly configure the environment. 

2.4.1. Installing the Arduino IDE 

 Download the Arduino Software (IDE) from https://www.arduino.cc/en/Main/Software. Run the installer “Arduino-xxxx-
windows.exe”, where “xxxx” is the IDE revision number. The oldest IDE revision number supported by the InvenSense ICM-
306XX eMD Developer’s Kit is 1.6.9.  In the Arduino Setup Installation options, select “Install Arduino Software” and also 
“Install USB driver”. The default IDE install path is “C:\Program Files (x86)\Arduino”. 
 

 Once the software is installed, run Arduino.exe 

https://www.arduino.cc/en/Main/Software
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The Arduino IDE software also creates an Arduino folder by default in “Documents library”. After installation, this folder will 
be empty. But it will contain custom programs written using Arduino IDE that are called sketches and custom libraries. 
These sketches are saved with the specific Arduino file extension .ino. 

 

 Configure the Board Manager in order to have access to the needed Arduino Zero package. 
 Click on Tools->Board: "xxxxxxxxx" -> Board Manager 

 

Figure 3 – Click on Board Manager  

 
 Select Arduino SAMD Boards and click Install.  

 

Figure 4 – Install Arduino SAMD Boards package 

Once the package for Arduino Zero is installed, click close. 

 Exit Arduino IDE. 

2.4.2. PC connection 

 Connect Arduino Zero board through Micro USB (PROGRAMMING port) and let the windows install the driver.  

Note: Arduino Zero comes with 2 USB ports. The backside of the board has labels for identification. Please refer to the Figure 5 
below. 
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Figure 5 – Connect to PC using USB Programming Port 

 
 On Arduino IDE, select the Arduino Zero programming port. Click on Tools->Boards->Arduino Zero (Programming Port) 

 

Figure 6 – Select Board: Arduino Zero (Programming Port) 

 Select the correct COM port. Click on Tools->Port-> COMxx (Arduino Zero (Programming Port)). To find the COM port 
number, open the Device Manager on your computer and look for the label “Atmel Corp. EDBG CMSIS-DAP” and the 
associated COM number. The Arduino Zero Programming port is connected to Atmel chip EDBG (please refer to 
https://www.arduino.cc/en/uploads/Main/Arduino-Zero-schematics.pdf). 

Note: The “Programmer” setting is not used in our configuration. This setting defines the programmer type able to program 
without using the Arduino bootloader. 

 

Figure 7 – Select Port: COMxx (Arduino Zero (Programming Port)) 

https://www.arduino.cc/en/uploads/Main/Arduino-Zero-schematics.pdf
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The Arduino Zero includes the Atmel Embedded Debugger (EDBG) to program the chip directly. The programmer setting (from 
Tools menu) allows using an alternate bootloader to flash the Arduino firmware. In our case, no additional step is required. 

2.4.3. Package installation 

 Install the InvenSense ICM-306XX eMD Developer Kit. Click on Sketch->Include Library -> Add .ZIP Library… 

 

Figure 8 – Add the .ZIP library 

Select the package Arduino_Zero_ICM306XX-eMD_xxxx.zip, where “xxxx” is the version number. You will see this message 
displayed to confirm the library is correctly add to custom library. 

 

Figure 9 – Displayed message when adding the InvenSense ICM-30630 library 

The InvenSense ICM-306XX eMD package is installed in the local Arduino documents directory (in “Documents library” by 
default). Inside you will find a directory named “Libraries”. The imported library directory is there. You will find the main 
InvenSense ICM-306XX library directory containing sources and examples (for more information about directory structure, 
please refer to Section 2.2). 

 Update the package version if available by reproducing the procedure above. 

When updating the ICM-306XX library version, the Arduino IDE installs the library at the same path defined above but in a 
different folder; the libraries are duplicates but give access separately to the two versions. The Arduino IDE will always 
automatically load the most recent library. If you want to load a previous version, you should remove the latest library directory 
directly from Arduino documents library location. 

2.5. COMPILING AND DOWNLOAD 

2.5.1. Compiling and download a sample from Arduino 

In order to verify the Arduino configuration, Arduino IDE provides a set of samples (also called sketches). For example, one of 
these sample will blink a LED. 

 Select the Blink example 
Click on File->Examples->01.Basics->Blink 
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Figure 10 - Select Arduino basic example: Blink 

 Build the sketch by clicking on “Verify” button 

 

Figure 11 - Click on Verify 

 Build and download the sketch. Click on “Upload” button 

 

Figure 12 - Click on Upload 

If the upload succeeds, you will see the yellow LED_L blinking every second. 

Troubleshooting: Please refer to Arduino website https://www.arduino.cc/en/Guide/Environment. 

2.5.2. Compiling and download a sample from InvenSense ICM-306XX library 

 Now you can select a sample code dedicated to ICM-306XX.  
Click on File->Examples->InvenSense ICM-306XX library ->”xxxxxxxxxxx” 
 

https://www.arduino.cc/en/Guide/Environment
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Figure 13 – InvenSense ICM-30630 library examples tree 

 Build the sketch by clicking on “Verify” button 
 Build and download the sketch. Click on “Upload” button 

 

The ‘GetExternalSensors’ sketches requires external sensors to be connected. Please make sure to have the sensor daughter-
board plugged-in. 

3. THE APPLICATION 
This section will described the application portion of projects using Easy Device library to communicate with the ICM-306XX 
eMD. This architecture is common to all samples application provided by InvenSense.  

3.1. START-UP IN .INO FILE 

The .ino file is the starting point at runtime. There is no difference with a .cpp file about the file format and the programming 
language. Every project must have a .ino or sketch file that containing the setup() and loop() function. 
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3.2. GENERAL APPLICATION ARCHITECTURE 

3.2.1. Application Setup Function 

The setup() function is where the board peripherals are initialized using Arduino API. For example, the serial interface setup is 
called to get traces. 

Also in this function, the Easy device library is initialized to start the communication with ICM-306XX eMD. In the Easy device 
structure parameters, there are callbacks functions (refer to Section 3.2.3) and all the images needed for setup. 

There are three major image loading steps needed to bring-up the ICM-30630 eMD: the firmware programming, the DMP3, and 
the DMP4 image loading. These images are given to the Easy device structure and are available in header files:  

- icm_30630_fw.h,  
- icm_30630_dmp3.h,  
- icm_30630_dmp4.h 

Note: DMP3 image loading is required only for ICM-30630. 

Note: The firmware programming step is optional, you can use DISABLE_FW_M0_PROG define to avoid reprogramming the ICM-
306XX eMD at each Easy Device initialization. 

Another requirement for the Easy Device setup is to provide a minimum of 4Kbytes buffer needed to read ICM-306XX eMD 
FIFOs before parsing data read through SPI. The bigger the allocate buffer is, the faster the communication will be. 

One last important step to bring-up the ICM-306XX eMD device is to set the reference frame. The reference frame describes the 
X/Y/Z axis reference and the convention sign for sensor data for the device. It depends on how the hardware sensors 
(accelerometer, gyroscope and magnetometer) are mounting on the board. The X/Y/Z axis reference on ICM-306XX eMD shield 
for accelerometer and gyroscope sensors is the figure below: 

 

 

Figure 14 - Coordinate system for reference frame 

 

The reference frame is computed according to the mounting matrix settings provided in the Easy Device structure. For the 
accelerometer and gyroscope (both being physically aligned), an identity matrix will set the default board orientation as 
described in Figure 14. For the external magnetometer on the Sensor Daughter-Board, the mounting matrix has to be aligned  
with the appropriate coefficients to match the desired orientation. 

It is possible to directly start a sensor after setting up the Easy Device library by calling inv_easy_device_start_sensor(). The user 
should specify the following parameters:  

- The device structure, already defined for the Easy device initialization 
- The sensor ID, (the full list of available sensors is available in InvenSense Device Driver library), refer to inv_sensor_type  

structure in SensorType.h header 
- The requested data period in milliseconds 
- The allowed timeout in milliseconds 
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3.2.2. Application Loop Function 

The loop() function checks notified events. 

For the Easy device, you may check flag reporting new data available through the Easy device library callback and calls data 
processing. Each data available event notification should be followed by the polling function inv_device_poll() in order to get all 
available data.  

3.2.3. Callbacks 

There are two callbacks to pass in parameters of the Easy device initialization function:  

- the interrupt callback, to notify there are data available in FIFOs, 
- the sensor event callback, to notify data reported.  

The interrupt callback is called under interrupt, so the code inside must be thread safe. The data processing should be done in 
another safe context. 

The sensor event callback is called when sensor data is received. For each sensor data the user has access to, there is a sensor 
structure containing sensor ID, status event, and all sensor data. This callback has two parameters available: 

- Event:  the sensor event structure, refer to inv_sensor_event structure in the InvenSense Device Driver library, see 
SensorType.h header 

- Arg: listener context 

3.3. SERIAL MONITOR 

How can the user verify that their code is correctly running? The Arduino Serial interface. You may refer to the sample codes 
printing traces on the Serial Monitor interface. This Arduino tool is a terminal window that communicates by receiving and 
sending serial data over USB. There are two serial interfaces available defined by Arduino on Arduino Zero: the “Serial” class for 
the USB Programming port and “SerialUSB” class for USB Native port. It’s recommended to use the USB Programming port. 
Refer to SERIAL_TRACES define in sample code in order to use the other port. The below step shows how to use the serial 
monitor in Arduino IDE: 

 Open the Arduino Serial Monitor 

 

Figure 15 – Serial monitor interface shortcut 

 
 Select the speed: 250000baud.  

Note: This baudrate is chosen and configured for the “Serial” class using USB Programming port for every sample code. 
Refer to SERIAL_TRACES.begin() function to change this speed parameter. 

 

Figure 16 - Serial monitor speed configuration 
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Then click on the reset button of the Arduino Zero board. You can watch traces generated by sketches on the serial interface. 

 

4. SAMPLES APPLICATIONS 

4.1. ACCELEROMETER AND GYROSCOPE CALIBRATION 

This sample code starts communicating with ICM-306XX eMD through the Easy Device library, starts the accelerometer and 
gyroscope sensors at 200Hz, and waits for a high accuracy value for these sensors. Once the calibration is done, c-style float 
tables with calibrated coefficient values are displayed on serial monitor. 

At start, the user will see these messages: 

 

Figure 17 - Traces at start 

For more information about how Easy device calls the InvenSense Device Driver library and the hiding process, additional traces 
can be enabled by a defined option MSG_LEVEL. 

When the accelerometer and gyroscope sensors start, the user will see the data reported. If the accuracy flag (AF) is set to ‘0’, 
that means the values reported by the sensor are unreliable; calibration is needed. 

 

Figure 18 – Non-calibrated accelerometer and gyroscope data events traces 

The calibration process will notify the accuracy flag value. There are several states: 

- ‘0’ -- the sensor needs to be calibrated 
- ‘1’-- the sensor is reporting data with low accuracy 
- ‘2’-- the sensor is reporting medium accuracy, the calibration may improve the reading values 
- ‘3’-- the sensor is reporting a high and maximum accuracy 

If the gyroscope calibration is static; you need to let the board static during several seconds in order to allow the gyroscope 
angular computation to define the offset values that can be adjusted by the calibration. 

If the accelerometer calibration is also static, you need to put the board on the four different axes for several seconds in order to 
get a uniformed gravity value. 

 

Figure 19 - Calibration process on four axes for accelerometer 

After these procedures, the accuracy flag of the accelerometer and gyroscope sensors should be set to ‘3’, the sketch then stops 
and you will see the calibration tables that are used to get the accurate bias. These tables could be copied and paste directly to 
another sketch in order to have calibrated value. 

 

Figure 20 - Configuration tables traces 
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As displayed, the sensors can restart when sending a character on serial monitor, allowing calibration coefficient tables. 

4.2. DOOR OPENING DETECTION  

This sample code reports an event when a door is opening, displayed by an LED blinking. On Arduino Zero, the LED_L will be on 
when the event is triggered for 5s, but if you connect a buzzer to Pin 13, you will hear a sound signal at 1 kHz tone. The 
detection is based on the custom sensor generated from SensorStudio Flow “Door opening detection”. First of all, you must 
program the ICM-306XX eMD board with this Studio flow. Refer to SensorStudio documentation for more information about 
programming the ICM-306XX eMD through Studio flow. SensorStudio updates the firmware image and when starting the Door 
Opening Detection Arduino sketch, the Icm30630 firmware image is not re-programmed. 

 

Figure 21 – Door opening detection sketch  

The Easy device initialization starts the communication with the ICM-306XX eMD board and enables custom sensor 0 at 10Hz. In 
order to get accurate detection of angle computed, we used Easy Device library to set bias for the accelerometer and gyroscope 
sensors. To have an accurate detection, it’s recommended to use the calibration sketch to compute the configuration coefficient 
tables for the accelerometer and gyroscope sensors before running  the opening door detection sketch (refer to Figure 19 
above).  

When the expected gesture is triggered, the LED turns on and you will see the following message printed on serial monitor: 

 

Figure 22 - Door opening detection trace 

4.3. GESTURE DETECTION  

This sample code reports events when specific gestures are detected. For triggered a TILT gesture, you have to hold the device 
and move 180 degrees. To trigger a “SMD” gesture (Significant Motion Detected), you have to move the device at least 10s. 

At start, the “Easy Device” initialization starts communication with the ICM-306XX eMD board and enables events for TILT and 
SMD gestures. When an interrupt coming from the ICM-306XX eMD is triggered, the Easy Device polls the data FIFO to report 
the event. 

After seeing the start messages: 

  For a tilt gesture, put the device on your hand and then reverse the device to point towards the ground. You’ll see on 
serial monitor: 

 

Figure 23 - Tilt gesture detected traces 

 For a SMD gesture, put the device on your hand and for example shake it during 10s. 

 

Figure 24 - SMD gesture detected traces 

4.4. GET ACCELEROMETER DATA 

This sample code starts the InvenSense Device Driver library using Easy device, enabling the accelerometer sensor at 20Hz with 
data buffering for a maximum of 500ms. The data polling appends when the data FIFOs are full or when 500ms elapsed. 

You’ll see on the serial monitor for each data reported the associated timestamp, the event number, and the acceleration value 
in milli-G for each axis X/Y/Z. 
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Figure 25 - Accelerometer data events reported at 20Hz traces 

It’s possible to stop the accelerometer sensor by writing a character on the serial monitor: 

 

Figure 26 - Stop sketch traces 

As displayed, the accelerometer sensor can restart when sending a character on serial monitor. 

4.5. GET EXTERNAL SENSORS 

This sample code reports externals sensors data: proximity, pressure and magnetometer. During the execution, data and traces 
are printed on the serial monitor. As those sensors are externals, at startup the Easy device sends a ping request to each sensor 
to verify if they are connected to the ICM-306XX eMD shield before starting the sensor.  

Verify that you see Serial Monitor: 

 

Figure 27 - Ping & Start Proximity sensor traces 

and equivalent traces for Pressure and Magnetometer sensors. 

Sensors are started at 1Hz, every second you’ll see data reported on serial monitor. For each, there is an associated timestamp. 
The magnetometer data is displayed in microTesla for each axis X/Y/Z. The pressure data is displayed in hectoPascal. 

 

Figure 28 - Magnetometer and Pressure sensor data events at 1Hz traces 

The proximity sensor is an “on-change” sensor that means the data is reported only if there is a different distance to the closest 
surface of the sensor reported. To see proximity data printed in the serial monitor, move your finger close to the Sensor 
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Daughter board connected to the ICM-306XX eMD shield. The proximity sensor will detect distance variation and reports sensor 
data in millimeters. 

 

Figure 29 - External sensors traces 

4.6. GET GAME ROTATION VECTOR 

This sample code gets quaternion data printed on serial monitor. The Easy device initializes the communication with the ICM-
306XX eMD board and starts the Game Rotation Vector sensor at 20Hz; this sensor name is an Android name to orientation 
based on accelerometer and gyroscope. Data are bufferized for a maximum of 500ms. The data are reported on ICM-306XX eMD 
interrupt when the sensor data FIFOs are full or when 500ms elapsed. 

For each data reported, there are an associated timestamp, an event number and the normalized unit value for each axis X/Y/Z. 

 

Figure 30 - Quaternion data events traces 

The sketch allows the user to start and stop the sensor in sending a character on the serial monitor, as described above in the 
GetAccelerometerData sample code. 
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5. SENSOR DATA FREQUENCIES 

5.1. SENSOR DATA DECIMATION 

When requesting several sensors at different frequencies, there are several mechanisms in ICM30670 FW in order to fit as much 
as possible user’s requests for each and every sensor. The firmware will always try to provide sensor data for a given sensor at a 
frequency being at least the frequency requested for this sensor. To do so, there is a two-stage sensor data decimation 
performed, one being configurable by the end-user.  

 

 

 

 

 

 

 

 

5.1.1. MTA : MEMS to Algorithm decimation 

Internally, accelerometer and gyroscope MEMS provide data to algorithms at the very same frequency. The quickest frequency 
requested, called fmax, is the frequency at which both accelerometer and gyroscope output data. 

In order to match slower frequencies for other sensors enabled, a simple internal decimation is done. It relies on the frequency 
requested for each sensor, fsensor, and feeds algorithm with sensor data every fmax/fsensor sample. 

For instance, if a user requests to enable a CalibratedGyroscope sensor at 50Hz and a GameRotationVector at 20Hz (which 
requests CalibratedGyroscope and CalibratedAccelerometer at the same frequency) : 

- accelerometer and gyroscope MEMS will output data at 50Hz 
- CalibratedGyroscope will feed its algorithm and output data at 50Hz 
- GameRotationVector will decimate once every 2 sample (being 50Hz/20Hz), hence leading to compute and output data 

at 25Hz, which is quicker than the frequency requested by the user 

This decimation stage is not configurable. 

 

5.1.2. ATU : configurable Algorithm to User decimation 

Before sensor data is indeed sent to Arduino board, it goes through a 2nd-stage decimation. This stage is configurable at 
SensorStudio level and can be either : 

- NONE : there is no decimation performed at this level, sensor data are forwarded at the frequency at which they go out 
from the algorithm 

- SIMPLE : sensor data is dropped if the time elapsed since last sensor data sent to user is less than 75% of requested 
data rate 

- ADVANCED : interpolate data if needed to ensure the actual frequency reported is the same as the requested, even if 
we have to fake the data 

For instance, if a user requests to enable a CalibratedGyroscope sensor at 50Hz, a GameRotationVector at 80Hz and a 
CalibratedAccelerometer at 40Hz. They will first go through first-stage decimation  

With the example described above, if user also requests CalibratedAccelerometer at 30Hz, it will go out of first-stage decimation 
at 50Hz, here is effective data rate seen at SensorStudio level with various ATU configurations 

Configuration CalibratedGyroscope data rate GameRotationVector data rate CalibratedAccelerometer data rate 

NONE 50Hz 25Hz 50Hz (first-stage decimation) 

SIMPLE 50Hz 25Hz 25Hz (does not fit dt<0.75*ODR) 

ADVANCED 50Hz 20Hz 40Hz 

 

Accelerometer 

Gyroscope 

MTA Sensor1 

MTA Sensor2 

MTA SensorX 

ATU 

… 

Sensor data 
to user 
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Similar to CalibratedAccelerometer case above, for proximity and pressure sensors, user must be aware that one side-effect of 
choosing SIMPLE decimator can be to get data slower than requested, even if enabled alone. 

For instance, let’s assume a pressure sensor enabled at 5Hz. Internally, the pressure sensor will be sampled at a power of 2 
frequency just above, being then 8Hz. As a consequence, SIMPLE decimator will receive a new pressure data every 125ms. 
Because of SIMPLE decimator rule, it will decimate incoming sample if the time elapsed since last pressure sensor data sent is 
less than 3*200ms/4 = 150ms. So every other two pressure sample will be decimated, hence leading to an ODR of 250ms, 8Hz, 
being slower than 5Hz as initially requested. 

 

5.2. FREQUENCIES 

The table below sums up the achievable frequency for each sensor, without any consideration of the decimation stages. 

Sensor Reporting Frequencies (Hz) Reporting mode Required Accel 
 frequency (Hz) 

Required Gyro  
frequency (Hz) 

Min Max 

Raw Accelerometer 4 1000 Continuous = x 

Accelerometer 4 1000 Continuous = = 

Raw Gyroscope 4 1000 Continuous x = 

Gyroscope 4 1000 Continuous x = 

Uncal Gyroscope 4 1000 Continuous x = 

Raw Magnetometer 4 100 Continuous x x 

Magnetometer 4 100 Continuous x x 

Uncal Magnetometer 4 100 Continuous x x 

Gravity 4 200 Continuous = = 

Linear Acceleration 4 200 Continuous = = 

Game Rotation Vector 100 1000 Continuous = = 

Geomag Rotation Vector 4 100 Continuous = x 

Rotation Vector 4 1000 Continuous = = 

Orientation 4 1000 Continuous = = 

Pressure 1 16 Continuous x x 

Ambient Temperature 1 16 Continuous x x 

Proximity 1 8 Continuous x x 

Pickup  One shot 50 x 

 

‘=’ means that the MEMS frequency will be the same as the corresponding sensor. 
‘x’ means that it doesn’t use the corresponding MEMS. 


